Sunday, September 25, 2022

Packet Tracer Lab 3 - Static Route and Default Route

A router is a network device that forwards data packets between computer networks. We need to configure routing on the router, so that it can select the best path to transfer the data packet from source to destination.

In this lesson, we will explain how to configure static and default route on the router.

We have Network A, B and C, as shown in the figure below.


We will configure default route on R1 and R3.

We will configure static route on R2.


This is the IP address we need to configure in every device.





ANSWER:


R1 Configuration

hostname R1

interface GigabitEthernet0/0

no shutdown


interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0


interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0


interface Serial0/0/0

ip address 10.10.10.1 255.255.255.252

no shutdown


ip route 0.0.0.0 0.0.0.0 10.10.10.2 


R2 Configuration


hostname R2


interface Serial0/0/0

ip address 10.10.10.2 255.255.255.252

no shutdown


interface Serial0/0/1

ip address 20.20.20.2 255.255.255.252

no shutdown


ip route 192.168.10.0 255.255.255.0 10.10.10.1

ip route 192.168.20.0 255.255.255.0 10.10.10.1

ip route 192.168.30.0 255.255.255.0 20.20.20.1


R3 Configuration


hostname R3


interface GigabitEthernet0/0

ip address 192.168.30.1 255.255.255.0

no shutdown


interface Serial0/0/1

ip address 20.20.20.1 255.255.255.252

no shutdown


ip route 0.0.0.0 0.0.0.0 20.20.20.2


S1 Configuration


vlan 10

name Net-A


vlan 20

name Net-B


interface FastEthernet0/1

switchport access vlan 10

switchport mode access


interface FastEthernet0/6

switchport access vlan 20

switchport mode access


interface GigabitEthernet0/1

switchport trunk allowed vlan 10,20

switchport mode trunk


All devices can ping with each other.


Saturday, September 17, 2022

Packet Tracer Lab 2 - Inter-VLAN Routing

VLAN stands for Virtual Local Area Network. It is usually configured on switches to divide a physical LAN into multiple broadcast domains. 

For example, all teachers' computers in a school could be assigned to the "Teacher" VLAN, while all students' computers could be assigned to the "Student" VLAN. In this way, VLANs can improve the efficiency and flexibility of a local area network.

We need a device that can do routing to communicate the computers on separate VLANs. Inter-VLAN routing is a process to forward network traffic from one VLAN to another VLAN using a router.

In this lesson, we will demonstrate how to configure VLAN and setup a router to enable the inter-VLAN routing.

We have 3 VLANs: VLAN10, VLAN20 and VLAN30, as shown in figure below.


In this demonstration, Port Fa0/1 of S1 and S2 will be configured as access port and VLAN 10.


Port Fa0/6 of S1 and S2 will be configured as access port and VLAN 20.

Port Fa0/11 of S1 and S2 will be configured as access port and VLAN 30.


G0/1 and G0/2 of S1 and S2 will be configured as trunk port, only traffic from VLAN10, VLAN20 and VLAN30 can be allowed to pass through.


This is the IP address we need to configure in every device.





ANSWER:


R1 Configuration

hostname R1


interface GigabitEthernet0/0

no shutdown


interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0


interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0


interface GigabitEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0


S1 Configuration

vlan 10
name Teacher

vlan 20
name Student

vlan 30
name Guest

hostname S1

interface FastEthernet0/1

switchport access vlan 10

switchport mode access


interface FastEthernet0/6

switchport access vlan 20

switchport mode access


interface FastEthernet0/11

switchport access vlan 30

switchport mode access


interface GigabitEthernet0/1

switchport trunk allowed vlan 10,20,30

switchport mode trunk


interface GigabitEthernet0/2

switchport trunk allowed vlan 10,20,30

switchport mode trunk

S2 Configuration

vlan 10
name Teacher

vlan 20
name Student

vlan 30
name Guest

hostname S1

interface FastEthernet0/1

switchport access vlan 10

switchport mode access


interface FastEthernet0/6

switchport access vlan 20

switchport mode access


interface FastEthernet0/11

switchport access vlan 30

switchport mode access


interface GigabitEthernet0/2

switchport trunk allowed vlan 10,20,30

switchport mode trunk


Friday, September 16, 2022

Packet Tracer Lab 1 - Static and Dynamic NAT (Network Address Translation)

NAT is an abbreviation for Network Address Translation. NAT is designed for IP address conservation. Before the data packets be transmitted to the outside network, NAT will convert the internal IP address to the external IP address. Therefore, it enhances the security of the internal network by keeping internal addressing private from the external network.

In this tutorial, we will study how to configure Static NAT and Dynamic NAT using Cisco Packet Tracer.

We have INTERNAL NETWORK and EXTERNAL NETWORK, as shown in figure below.

Dynamic NAT will be configured at R1 router.


Static NAT will be configured at R2 router.


This is the IP address we need to configure in every device.





ANSWER


From the observation, we notice that devices in INTERNAL NETWROK can ping External Server's NAT IP address only.


R1 Configuration

interface GigabitEthernet0/0
 ip address 192.168.15.1 255.255.255.0
 ip nat inside

interface Serial0/0/0
 ip address 202.111.222.10 255.255.255.0
 ip nat outside

ip nat pool DYNAMIC 202.191.2.5 202.191.2.6 netmask 255.255.255.252
ip nat inside source list 1 pool DYNAMIC
access-list 1 permit 192.168.15.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 202.111.222.20 

R2 Configuration

interface GigabitEthernet0/0
 ip address 10.10.10.254 255.255.255.0
 ip nat inside

interface Serial0/0/0
 ip address 202.111.222.20 255.255.255.0
 ip nat outside

ip nat inside source static 10.10.10.50 202.191.2.1 

ip route 202.191.2.4 255.255.255.252 202.111.222.10 

Packet Tracer Lab 3 - Static Route and Default Route

A router is a network device that forwards data packets between computer networks. We need to configure routing on the router, so that it ca...